Erro ao inicializar o Blender em placas de vídeo antigas

  • 30 de Julho de 2018
  • Em Dicas

Tive que instalar o Blender 2.79 em um notebook mas o programa não abria, quando chamei o blender pelo shell apareceu a seguinte mensagem.

"Error! Blender requires OpenGL 2.1 to run. Try updating your drivers."

Descobri que este erro é porque a placa de vídeo (ou o drive do Ubuntu dela não sei dizer ao certo) não da suporte ao OpenGL 2.1 que é um pré-requisito das versões mais novas do Blender, após alguns minutos de google achei uma dica neste fórum https://ask.fedoraproject.org/en/question/110917/unable-to-open-blender-requirs-opngl-21-to-run-how-to-fix-it/ que resolveu o problema.

No terminal chame o blender com o seguinte comando.

$ MESA_GL_VERSION_OVERRIDE=2.1 MESA_GLSL_VERSION_OVERRIDE=210 blender

Caso de certo, vamos criar um script para chamar o blender da forma correta.

1. Criei um script com o nome blender.sh no meu diretório padrão

$ echo "MESA_GL_VERSION_OVERRIDE=2.1 MESA_GLSL_VERSION_OVERRIDE=210 blender" > ~/blender.sh

2. Depois dei permissão de execução para ele

$ chmod +x blender.sh

3. Execute no terminal o script para ver se deu certo.

4. Agora basta criar um atalho na área de trabalho chamando o script.

Sobre o Dicas TI

Somente mais um site sobre internet, tecnologia, desenvolvimento e programação. Uma forma de, tentar, devolver o que aprendi na internet através de pesquisas e estudos. E como falou o pensador Joseph Joubert “Ensinar é aprender duas vezes” mas não se engane aqui você encontrara somente um leve rascunho uma tentativa de ensino e nada mais.